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Are You Prepared for
a Disaster?

Picture this: One day you turn on your computer
and nothing happens… Your hard drive has
died! Has this happened to you yet?

I say “yet”, because if it hasn’t,
chances are that it will someday.
Even with the best of maintenance
and care, hard drives can fail unexpectedly.
Sometimes the data on the drive can be recovered through the use of disk repair 
but not always. The data on your hard drive can be lost in other ways as well. Co
can be stolen or destroyed by fire; laptops can be lost or stolen; and individual file
folders can be deleted or overwritten by mistake.

Regular backups can make the difference between a major disaster and a relative
inconvenience. With a recent backup of your entire hard drive you can reformat th
(or purchase a new one) and restore the contents in just a few steps. Even if you 
backup your data you can still reinstall the operating system and your application
then restore all of your files and folders. But without a regular backup, you could l
everything. Depending on what you store on your computer, this could represent 
months, or even years of lost work.

BACKING UP YOUR COMPUTER
There are many backup strategies for safeguarding your data. One of the easiest
strategies at HMC is to store your important data files on one of the central serve
campus. All of the main servers on campus, including Orion, Thuban, HMCADM, Kato,
Lurch, Igor, and the departmental machines such as Turing and Aslan, are backed up
regularly. So any files that you store on these machines are backed up for you; yo
need to worry about them.  Administrative staff can store their files on Lurch. Faculty
can store their files on Kato or Igor and academic staff can store files in their home
directories on Kato. Students can use Kato to store their files as well.

Another easy strategy is to make backup copies of your important files onto anoth
medium such as a floppy disk, ZIP cartridge or even an external hard drive. There are
some obvious disadvantages to this strategy, however. As hard drives get larger it’s n
easy or as practical as it used to be to fit the files you want to backup onto floppies or
ZIP drive. Backing up your system and application files in this way is also not practica
main problem, though, is having the time and the discipline to actually perform your b
The best backup system in the world is no good if it’s not done regularly.

The administrative staff have only recently all started using PC’s and it was relativ
easy to set up their PC’s so that, by default, users’ files are saved in their home
directories on Lurch. The diverse mix of computer platforms and the lack of a stand
software “image” make it difficult to use the file server as an (continued on page 5)
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The newest release of the Macintosh
operating system software is Mac OS 8.5
which was released in October 1998. CIS
did not immediately upgrade to OS 8.5 du
to some early reports of upgrade problem
and conflicts. However, these problems
were addressed in a recent update, and w
have now upgraded our Macintosh labs to
Mac OS 8.5. New Macintosh computers
are also arriving with OS 8.5 installed so
we thought this would be a good time to
introduce you to some of the new feature
of the operating system.

SHERLOCK
The most widely reported, and probably
the most fun, new feature of the operating
system is Sherlock, the Macintosh’s new
Find utility. Selecting Find from the File
menu in the Finder or selecting Sherlock

from the Apple menu brings up the new
Find dialog box, which is now called
Sherlock. The dialog box has three tabs.
The first tab is Find File. It is basically the
old find utility which lets you find files on
your hard drive by file name or other file
attributes. The second tab is Find by
Content. You can now find a file by
searching the content of the files on your
e
s

e

hard drive. After telling Sherlock to first
index the contents of your hard drive
(which may take a couple of hours the firs
time), you can type keywords in the searc
field and Sherlock quickly brings up a list
of files that contain those words.

The third tab allows you to search the
Internet by simply typing keywords or
phrases in the search field. Sherlock uses
multiple Web search engines
simultaneously to find Web sites that
match your search. The results are return
with great speed in a single list ranked by
relevance. Double-clicking on a result
launches your preferred Web browser and
retrieves the Web page for you. You can
even save your search criteria for later us

FAVORITES
OS 8.5 has many other exciting new
features. Most Macintosh users are familia
with the Apple menu items folder in the
System Folder. A new feature, Favorites,
allows you to create aliases to documents
applications, zones, servers, and volumes
as well as to Internet locations such as W
pages and email addresses. The Favorite
feature is easy to use: just select the item
the Finder and use the Add to Favorites
command under the File menu. The great
advantage of the Favorites feature is that 
not only appears under the Apple menu,
but in the Network Browser and the new
Save and Open dialog boxes (more on
these below).

SAVE & OPEN DIALOG BOXES
The Save and Open dialog boxes have
been completely redesigned. The scrolling
window of files and folders now includes a



Occasional Downtime is arriving
a little late in your mailboxes this
month. CIS has been hard hit by illness
this semester and Occasional Downtime
has suffered as a result. Hopefully you’ll
find this issue to be worth the wait.

Our main article is about backing up
your desktop computer. CIS cannot
emphasize enough the importance of
backing up your data so we hope you
will read this article.

This month we are also featuring an
article about the new Macintosh
operating system, Mac OS 8.5. We
recently upgraded the Macintosh lab to
OS 8.5 and we’re taking this opportunity
to introduce our users to it’s new
features.

And finally, we have an article by
Michael Cope (HMC, ’00) on the LDAP
directory server. If you haven’t used the
LDAP directory server you should give
it a try. We include instructions for
configuring Eudora Light and Netscape
to access LDAP. The article also
includes important information for
students for using LDAP to control
access to information on their Mudd
Shots pages.

—Elizabeth Hodas

Occasional Downtime is published bimonthly

by the Computing and Information Services
Department at Harvey Mudd College. It is also

available in a variety of formats on the HMC Web

Server. Comments and questions can be directed
to downtime@hmc.edu. 3
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Date Modified column. The window can
be sorted by either column, in either
ascending or descending order. Best of a
it is now possible to open several files at
once by using the Shift key. The Save an
Open dialog boxes also feature three very
useful buttons. The Shortcuts button lets
you quickly connect to AppleShare server
The Favorites button shows the list of
items in your Favorites folder, while the
Recent button shows a list of recently
opened documents and folders. If you’ve
ever been frustrated by having to cancel
out of a save or open operation because
you’ve forgotten to login to Kato, Lurch,
or Igor, then you will appreciate the
Shortcuts button in particular.

Unfortunately, the new Save and Open
dialog boxes only appear in applications
that support them, so you may have to wa
until the next upgrade of your favorite
applications to see them.

NETWORK BROWSER
The Network Browser is a completely new
utility. It is similar to the Network
Neighborhood feature in Windows 95 and
98 in that it allows you to view all
AppleShare servers on the network
grouped by AppleTalk zones. You can use
the Network Browser to connect to a
server such as Kato or Lurch.

The Network Browser also features the
Shortcuts, Favorites and Recent buttons.
this context the Shortcuts button lets you
login to a server using its IP address. The
Favorites button      (continued on page 6)
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Introduction to the
LDAP Directory Server
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As many of you already
know, we introduced a new

directory server last fall at HMC
which coordinates email, phone, and

other information in a central database.
The directory is accessible by Web, finge
or with specialized LDAP clients. The
purpose of this service is to allow studen
and faculty to access directory informatio
control access to their own information,
and change some of their information
including controlling where their Mail
Central email address
(FirstName_LastName@hmc.edu) is
forwarded to.

THE LDAP PROTOCOL
The backbone of this service is the
Lightweight Directory Access Protocol
(LDAP). The LDAP server is a TCP/IP
service, much like a Web server or FTP
server, which provides a uniform interfac
to the database. LDAP clients, including
recent versions of Eudora, Netscape
Messenger, Outlook Express, and Pine, 
directly connect to the server and use it a
a remote address book (see sidebar). Th
is also a finger gateway (finger
help@hmc.edu for more info) and a Web
gateway (http://ldap.hmc.edu/).

ACCESS CONTROL
It is important to us (as well as required b
law) that you be allowed to decide who
gets to access your information. We use 
simple access control model that divides
access into four categories—none, local,
Claremont-wide, and foreign—for each s
of attributes. You can decide what group
(yourself, all HMC, all Claremont, or
everybody) you want to allow to view eac
set of attributes. Since access control is
s
,
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enforced at the server, all the different
gateways will automatically respect your
access control decisions. By default,
students’ access control is set to local and
faculty/staff is set to Claremont. More
complete information about access contro
is available on the Web gateway.

THE WEB GATEWAY
The Web gateway is the most flexible
interface as it allows you to modify your
information, including access control
information. To modify your entry, search
for yourself, then click on the Modify
option at the bottom of the entry display.
You can then enter your password (Orion
for students, Thuban for faculty and
academic staff, and HMCADM for
administrative staff) and change the
information you desire. Read the
instructions before changing Forwarding
Address or acl-list. Those change the ema
address your Mail Central addresses are
forwarded to and how your entry can be
accessed, respectively. Any email address
change takes effect the following morning
around 6:30 AM.

MUDD SHOTS
The Course and Dorm Mudd Shots pages
(Web pages that include information about
students in courses and dorms) now use
student home pages that are generated
automatically using data from the LDAP
directory. This means that students can
now control access to the information
displayed on their Mudd Shots page
selectively. For example, if you don’t want
your dorm room number displayed on you
Mudd Shots page you can use the Web
gateway to the LDAP server to change the
access control list to include “room-none.”
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Backup continued from page 1

effective backup on the academic side,
however. A catastrophic crash means no
only lost work, but significant time and
effort by both the user and CIS staff to
recover as much data as possible and to
restore the computer to a usable state. F
these reasons CIS has been testing a ne
backup server to regularly backup deskto
machines in the academic departments.

RETROSPECT BACKUP SERVER
The backup server being tested runs
software called Retrospect. Retrospect is
produced by Dantz Development
Corporation and is a popular backup
package for the Macintosh. Dantz recent
developed a backup client for Windows 9
NT so Retrospect can now be used to
backup both Macintosh and Windows
computers over the network. The backup
client software is installed on each
computer on the network that is going to
be backed up.

The software uses backup scripts that ru
automatically during the night so that use
do not need to worry about initiating the
backups themselves. The data is backed up
to a DAT drive attached to the backup serv

We first tested the backup server by usin
it to backup the desktop machines in the
CIS department itself. We are now
expanding to add the Physics, Chemistry
and Humanities and Social Sciences
departments. Each department is backed
on a different night of the week. The
backups are performed only once a week
so users will still be responsible for
backing up important documents they are
actually working on. Once we have the
backup system working smoothly we will
also add the Office of College Relations
and the Dean of Faculty’s Office. z
5

CONFIGURING YOUR EMAIL CLIENT
TO USE THE LDAP ADDRESS BOOK

NETSCAPE 4.XX

Select Edit->Preferences->Mail &
Groups->Directory->New. Enter the
following information in the boxes.

Description: Whatever you want
LDAP Server: ldap.hmc.edu
Search Root: o=Harvey Mudd
College,st=California,c=US
Port Number: 389
Maximum Number of Hits: (blank)

The LDAP directory can be accessed
by selecting Address Book from the
Communicator menu. In the
Directory list click on LDAP and
type in your search string.

EUDORA LIGHT

Select Tools->Options on the PC or
Special->Settings on the Macintosh.
In the box labeled Finger enter
“hmc.edu”. Click OK.

To search the LDAP directory, select
Directory Services from the Special
menu on the Macintosh or from the
Tools menu on the PC (the command
may also be called “Ph” in older
versions of Eudora). Type your query
in the search box and click the Finger
button.

PINE 4.X
Pine 4.x on Orion is already
configured to use the LDAP
directory. Press ^T from the header
line to use the LDAP address book.

Faculty members, and you yourself will b
able to override and see all the informati
that is available on Mudd Shots including
Advisor information. Mudd Shots can be
found from the Directory Services Page
http://www.hmc.edu/dir/. z

by Michael Cope (HMC, ’00
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Mac OS 8.5 continued from page 3

accesses the items in your Favorites fold
and the Recent button allows you to
quickly access recently used servers.

SMART SCROLLING
Another new feature is called Smart
Scrolling. The scroll bars at the right side
and bottom of windows have been
redesigned to include both up and down
arrows at the bottom and right ends of the
scroll bars. The scroll box on the right sid
of the window resizes according to the
visible content of the window.

FINDER VIEWS
In addition to Smart Scrolling, windows in
the Finder have some additional new
features. The title bar of a folder or volum
window contains an icon that can be used
to quickly move or copy the folder or
volume and its contents. Just drag the ico
from the title bar and it is as though you
had dragged the icon of the folder itself.
The width and order of the columns in list
view can be changed. You can also set
standard views for list, icon, and button
er

e

e

n

views in the Views section of the Finder
Preferences window. These settings apply
to all Finder windows, unless you
customize a particular window’s view
options.

INTERNET CONTROL PANEL
You can now specify your preferred email,
news and Web browser in the new Interne
control panel. With the new ability to
create Internet aliases, you can create an
alias to an email address, Web page,
newsgroup, or server by selecting it and
dragging it to the desktop.

When you open the alias, from the
Favorites list for example, your email
client or Web browser will automatically
launch. In the case of the Web browser it
will immediately go to that Web page. In
the case of the email client it will create a
blank email message addressed to the
email address of the alias.

APPLESCRIPT
AppleScript is Apple’s scripting language
which allows you to automate many tasks
on your computer. OS 8.5 features a new
version of AppleScript written entirely in
native PowerPC code, so your scripts will
run up to five times faster than before.
AppleScript scripts can now be attached to
folders that respond to folder actions, such
as opening or closing the folder, moving or
resizing the window, or adding or
removing items.

Some other new features include a
redesigned Apple Help system, a tear-off
application switcher palette that allows you
to quickly switch between applications,
and the ability to set the time and date
using network time servers based on the
worlds’ atomic clocks. Network file
copying performance has also been
enhanced.  z
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PAGE ORIENTATION IN MS WORD
Have you ever had an MS Word document
with a table that was too wide to fit on the
page? Well, there’s a relatively easy way to
fix this problem. You can change the page
orientation of selected pages from portrait
to landscape mode.

In MS Word 97 on the PC, first select the
text and/or table that you want to be
printed in landscape mode. Select Page
Setup from the File menu and click on the
Paper Size tab. Make sure that “Selected
Text” is selected from the pop-up menu
labelled “Apply To:” and then click the
Landscape radio button. Click OK. To
check the results, click the Print Preview
button in the Standard Toolbar.

Word automatically inserts section breaks
before and after your selection.

In MS Word 98 on the Macintosh the
procedure is essentially the same. After
selecting the text and/or table, select Page
Setup from the File menu. Click the
Landscape radio button. Then select MS
Word 98 from the pop-up menu in the
upper-left corner of the dialog box and
make sure that “Selected Text” is selected
in the “Apply size and orientation to:” box.
z

More CIS News
FTP SERVER
In order to save precious bandwidth and
provide faster downloads for popular
packages, we have started FTP mirroring.
FTP mirroring refers to the practice of
creating an exact copy of an archive on the
Internet on another server. The copy is
created automatically by mirroring
software and is usually updated daily.
Using a local mirror site instead of the
remote server saves the user time and cuts
down on network traffic. We currently
have Netscape 4.xx, the GNU archive, NT
service packs, Red Hat Linux 5.2, Red Hat
Linux updates, and FreeBSD 3.1 on our
FTP site.

You can get more information on the FTP
mirror at http://www.hmc.edu/comp/
ftp/. There are also instructions on doing
a Red Hat 5.2 upgrade or install over FTP
(it takes about 20 minutes). You can also
access the site directly through FTP at
ftp.hmc.edu/pub/mirrors/.

CLAREMONT NEWS SERVER
For many years, HMC has hosted a UseNet
news server for the use of all of the
Claremont Colleges. In order to support
the approximately 16 thousand discussion
groups, it takes a tremendous amount of
resources. One of the most important
resource was incoming traffic bandwidth
on our connection to the Internet. The
news server was consuming about 5% of
the connection, 24 hours a day. This was to
support a daily news readership of 125 users.

The bandwidth consumed by local readers
is far less than what is needed to support
an entire server. It was decided, therefore,
to outsource the news server to an off
campus location. This was done in mid
January. The results have been better than
expected. The new server is several times
faster, has twice as many discussion
groups, and provides a longer article
retention time. z
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Q: Can I import bookmarks from
Netscape on one computer to Netscap
on another computer?

A: Netscape bookmarks are actually just
stored in a text file so it is pretty easy
to import them to another copy of
Netscape. First you need to locate the
bookmarks file on your computer. On
the Macintosh the Netscape bookmark
file is called bookmarks.html and is
usually located inside the Netscape
Preferences folder in your System
Folder. On the PC the bookmarks file 
usually located in the Users directory
inside the Netscape program directory
on your hard drive.

Once you’ve found the file you need to
transfer it to the other computer. You
can copy it to a floppy, email it, or
copy it to Kato or Lurch, whichever is
most convenient for you. After you
have copied the file to the second
computer, launch Netscape
Communicator. Select Edit Bookmarks
from the Bookmarks menu on the
Macintosh or from the Communicator
menu on the PC. From the File menu
select the Import command. Select the
file you want to import and click the
Open button. You can use the Edit
Bookmarks window to rearrange and
organize your bookmarks once you’re
done importing them.

Q: I want to use Eudora to check my ema
from home. Can I do this?

A: To use Eudora at home you first need
to be setup for dial-in access using PP
(Point-to-Point Protocol). PPP access 
available to HMC faculty and staff and
to students by special permission. PPP
dial-in is different from terminal
emulation dial-in in that it allows you
to use TCP/IP applications such as
Eudora and Netscape over a phone
line. You can contact Elizabeth Hodas
at extension 7-4583 for more
information on getting PPP access.

Once you have PPP dial-in access you
can use Eudora at home just as you
would in your office. If you need help
configuring Eudora there is a cheat
sheet available in the CIS main office.

The only complication with using
Eudora on more than one computer is
that it can lead to your email being
divided up and stored on multiple
machines. This is not usually desirable
so you need to first decide which
machine will be the central repository
of your email. Usually this is your
office machine. Then you need to
configure any other machine that you
use Eudora on to use a feature of
Eudora called “Leave mail on server.”
On those machines Eudora will retrieve
your new email but will leave a copy
on the server. When you return to your
office all of your new email will be
downloaded to your office computer
and deleted from the server.

To configure Eudora in this way select
Options from the Tools menu on the
PC or Settings from the Special menu
on the Macintosh. Click the Checking
Mail icon and check the box labelled
“Leave mail on server.” Please do not
use this feature on your office
computer! If you never delete mail
from the server Eudora will eventually
timeout trying to retrieve your new
mail. z
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